BackTrack5: Metasploit 4 with PostgreSQL

يبدو إن هناك تغييرات عدة حصلت في Metasploit 4 ومن بينها طريقة التعامل مع قواعد البيانات … سأحاول في هذه التدوينة ان أللخص أهم الأمور، وكذلك بعض المشاكل التي قد تواجهك حين تود تشغيل القاعدة مع Metasploit على Backtrack5 … وكذلك ينصح مطوري Metasploit أن يتم إستعمال PostgreSQL بدلا من أي قاعدة بيانات أخرى …

في البداية توزيعة Backtrack5 لا يأتي راكب عليها قاعدة البيانات PostgreSQL ولهذا علينا تركيبها … أمرها سهل جداً:

apt-get install postgresql libpq-dev

والآن لنقوم بتشغيلها:

/etc/init.d/postgresql-8.4 start

بعد ذلك لنقوم بإضافة مستخدم وقاعدة لغرض التجربة … أعمل التالي:

su - postgres

ثم لنقوم بدخول نظام قواعد البيانات PostgreSQL من خلال:

psql

Continue reading